Products.CacheSetup and eea.facetednavigation: compatibility problems in PLONE 5?

I have installed eea.facetednavigation in a PLONE 5.0.7 Site. After the buildout the restart of the site did not work. plonectl -fg showed the error "Could not import Products.CacheSetup".
When I made a new buildout without having Products.CacheSetup in the buildout.cfg, the restart worked and I could activate and cutomize a new search with facetednavigation.
But then the "Contents" function for folders did not list anymore the folder contents. Only when I reloaded the page with the ctl Button pressed, it showed the folder content as expected.
So it looks like a caching problem.

When I make a build out on a test site - were facetednavigation never was installed - without Products.CacheSetup still everything works fine.

But: when I run a rebuild on my first mentioned site after having facetednavigation uninstalled, I still get the "Contents" problem.
When I tried to build the site with Products.CacheSetup - without facetednavigation - it still does not restart due to "Could not import Products.CacheSetup"
That means, now I can not rebuild and restart the site even if I have rebuilt it with the same products as it had before I had installed facetednavigation.

Has anybody any clue on that?
Thanks for any help.

Products.CacheSetup isn't recommended anymore; it's very old; instead, for Plone 5, use

Ok, thanks for the rapid answer. I'l try it.