Problem Installing quintagroup.dropdownmenu

Hello everyone, I have problem with installation of drop down menu. Installation is performed on plone 5.1.4 but it isn't working i got this:

We’re sorry, but there seems to be an error…
Here is the full error message:

Display traceback as text

Traceback (innermost last):

Module ZPublisher.Publish, line 138, in publish
Module ZPublisher.mapply, line 77, in mapply
Module ZPublisher.Publish, line 48, in call_object
Module plone.z3cform.layout, line 63, in call
Module plone.z3cform.layout, line 47, in update
Module quintagroup.dropdownmenu.browser.controlpanel, line 36, in update
Module quintagroup.dropdownmenu.browser.controlpanel, line 44, in _overrideValue
AttributeError: can't set attribute

anyone can help me?

I'm guessing quintagroup.dropdownmenu is not compatible with Plone 5.
By the looks of it https://pypi.org/project/webcouturier.dropdownmenu/ does support Plone 5.

Have you checked this page? I followed those instructions a year or two ago and had it working (mostly, slight gap between menu bar and the dropdown menu) in Plone 5.0.5, later updated to 5.0.8 and then to 5.1. Good luck.