Possible problems with cache busting the default resource bundle. Livesearch mockup pattern override only works on some requests and not on others

I have a question surrounding the Resource Registry, bundling resources, merging them into existing bundles. Refer to: https://docs.plone.org/adapt-and-extend/theming/resourceregistry.html

I have a customization that overrides the LiveSearch mockup pattern as described here: https://plone-training.readthedocs.io/en/master/javascript/exercises/8.html

The only thing the customization does is it reads an input called searchFilter that has been added to the livesearch form and is set by a drop down that supplies it was special scopes to search within. So the mockup pattern customization is the original implementation plus a searchFilter sent to @@ajax-search:

// set the search filter based on user selection or default to '*'
      var searchFilter = $('.searchFilter input').val() || '*';
      $.ajax({
        url: self.options.ajaxUrl + '?' + query +
             '&page=' + page +
             '&perPage=' + self.options.perPage +
             '&searchFilter=' + searchFilter,
        dataType: 'json'
      })

It worked fine with Plone 5, but when I moved to Plone 5.2, it only worked on some requests. I inspected the network requests in my browser and saw that sometimes it passes a searchFilter, and sometimes it does not. Since I merge it with the default bundle, which is also classified as a stableResource, what would be the best way to cache bust it? Stable resources have a max-age of a year under my policies.

Thank you for any insight!

Plone Foundation Code of Conduct