Plone User with a disability

Hi, I'm blind, I'm trying to use Plone, but get an error when saving preferences, also no way to change my log in. Using Plone 5.0, should I tell my web host we should upgrade?

Please include the exact error message.

Looks like it's working now, just wondering if I should still upgrade?

5.2 is out and dot zero releases of Plone are notoriously buggy

Why doesn't Plone auto-upgrade?

1 Like

For a bunch of technical reasons.

At least upgrade to the latest 5.0 oder 5.1 release.

Read the upgrade/migration docs.

I need someone to upgrade my site.

https://docs.plone.org/manage/upgrading/index.html

https://plone.com/providers.html

I did email someone, but what do I do in the meantime? I'm blind, can't I copy the upgrade into the Plone site? Can someone in the community upgrade the site?I don't have a developer.

The Plone upgrade and migration path for content is documented for everyone doing the upgrade for you.

Thanks, trying another Cms.

Plone 5.0 was released more than 4 years ago in September 2015.
So testing a CMS in some old release makes no sense.

Decent Plone 5.2 installations can be found here:

https://plone.com/try-plone.html

Or use my own https://www.plone-demo.info instance.

(site-wide reset after 12 hours).

Plone Foundation Code of Conduct