Plone Portlet Right column

For a folder I have created a mosaic view as display. I dont want the portlet to be visible on this display view for the folder but it needs to be present in the content pages below.
I dont find any TTW options to achieve this.

Possible solution:

  • use a default page using a collection for your folder view
  • set portlet on folder
  • hide on default page

thanks Nathan. unfortunately this does not work.
I create a collection and use it as default view. Place the portlet. Then hide the portlet. this does not work.

I create the collection and use it as default view. place the portlet. then i change the view to the mosaic view. this too does not work as individual pages in folder do not have the portlet.

What you need to do is

  1. Enable the portlets at the folder
  2. Disable the portlets at the default page

When you edit the portlets at the default page, it will give you a 'warning' about:
You are editing the default page, if you want to .....
Click on that link in the message.

Actually I am using a mosaic layout view. Hence the challenge. guess we have to wait till portlets are embedded into the mosaic layout.

Can't you create a page, with the mosaic view enabled and set it as the default view of the folder and then do what was recommended?

will do that and update

Cant do it with mosaic view enabled.The mosaic view is only available at the folder level. there is no mosaic views for the page or collection etc.

The recommended steps work for a non-mosaic view. my install of the mosaic is not the final release though. it was the rc1 version. will check this when i install the final version later.


hhmm, the view should be enabled for multiple types:

The RC1 release was the same in this manner.

i have raised an issue in github. may be it can be looked at sometime. Nothing urgent on this right now. will check for some other try arounds.

i terms of page loading what is the difference between a portlet and tiles / mosaic. Portlets being an older tech is it good enough

I dont think you are correct about this (it must be something else (?))

Do this

  1. Add a folder 'Myfolder'
  2. Add a few pages in the folder: Page1, Page2, Page3
  3. Enable the portlets on 'Myfolder', they should now show on Myfolder, Page1, Page2 , Page 3
  4. Block portlets on Page1
  5. Set View of Page 1 to 'mosaic view'. If this is not available, you are either using Archetypes for Pages, or you have not enabled the 'Layout support' behavior for Pages.
  6. Set default view of 'Myfolder' to Page1
1 Like

thanks. i need to check for point no. 5. the pages i am using are a dexterity content type clone of the page. let me check
Checked the same. Now I get the mosaic layout display at the page level. So the issue should be resolved. Thanks

Achieved the required results. Thanks. @vangheem @espenmn