Plone buildout fails -> PyXML

Hi all,
since a few days my buildout fails.

Getting required 'PyXML>=0.8.3'
  required by ZSI 2.0rc3.
We have no distributions for PyXML that satisfies 'PyXML>=0.8.3'.
Getting distribution for 'PyXML>=0.8.3'.
  Installing client1.
  Getting distribution for 'PyXML>=0.8.3'.
Error: Couldn't find a distribution for 'PyXML>=0.8.3'.

It seems that the package on pypi has gone?!
Can someone help me? I have a Plone in version 4.1 (but fails also in my upgraded 4.3)

yes, the owner seems to have deleted it from PyPI; there's nothing we can do here to help you:

Sorry, it seems to be dead...

Have a look:

Seems like your problem is with ZSI (and possibly by proxy, z3c.soap) -- this is not part of Plone.

Do you use/need SOAP support? You might need to investigate alternatives (including modifying ZSI to use an alternative DOM implementation) to do so.


Try to get it from here:

It should be enough to modify your buildout like this:


You may also have some luck building an egg from

Unfortuantely, yes I need a REST support. I try to get rid of ZSI.

You don't need SOAP (or ZSI) for REST, and they tend to compete in approach. That said, you ought to be able to consider an alternative like plone.restapi.


!!! That's astounding ... why would anyone do that?

I resurected the thread. I need SOAP for one of my projects. (collective.fims)

the PyPi url does work now.

But buildout still fails:
Error: Couldn't find a distribution for 'PyXML>=0.8.3'.
Error: Couldn't find a distribution for 'PyXML>=0.8.4'.
Error: Couldn't find a distribution for 'PyXML'

If this can be fixed, I'd like to volunteer to work on it.

I've never worked on PyPi distribution before. Is the problem there or is it in the ZSI

additional_params['install_requires'] = [ "PyXML >= 0.8.3", ]
additional_params['setup_requires'] = [ "setuptools >= 0.6c3", ]
additional_params['dependency_links'] = [

Well, that dependency_link from ZSI is dead.

So I went to sourceforge and found one of the mirrors.

Then put this into my own and things began to work:

        # -*- Extra requirements: -*-
        'PyXML==0.8.4' #because ZSI dependency links are borked

Please comment as to why this is a bad idea, and what the better idea is.