Plone 5: Registry bundles: compiling doesn't consider new JS code

i'm trying to update JS code within a registry bundle.


After changing JS code within e.g. '++theme++ems.web/ems_config.js' and clicking 'compile' on '@@resourceregistry-controlpanel' the new built bundle doesn't provide the new JS code.

Invoking '++theme++ems.web/ems_config.js' returns the new JS code.

I have tried:

  • deleting the bundle on '@@resourceregistry-controlpanel'' and re-adding it running the profile providing that registry.xml: does not help
  • restarting client: does not help
  • purging cache: does not help

I'm using:

  • Plone 5.0.6rc1
  • no webserver/apache/varnish/etc.

Is there something i miss ?

Thanks, maha

Hi Maha,

I suggest you for javascript to read this articles.

JavaScript for Plone develeopers
Check debug modes


Sadly, anything from is likely to be outdated and no longer applicable to Plone 5. Almost all the sites I and others wrote "how to"s for on that site were Plone 3 and 4. @bledwell and I have tried to get that !@$# site to display publication date but can't get it to work. Otherwise you'd see that that article was written on Apr 16, 2009

1 Like

Thank you so much for this infos.
I didn't pay attention on dates :pensive: but I saw the last modifications at 2016.

Thank you for this and sorry If I gave wrong infos to the @maha user.

There's no way you could have known since that site doesn't display publication date.

1 Like

...and now I see that the dates finally are appearing. I'd made the configuration change a few days ago but didn't see them take effect, probably because of caching.

1 Like

thank you for your answers.
I found out, that there is a problem using browser Firefox (52.0.2):
If there is a missing resource required by the bundle, clicking the 'compile' button within 'resourceregistry-controlpanel' will finish in a view, which is indicating the compiling is finished successfully. But there is no generation of the bundle file within portal_resources (of course).

Using browser e.g. Chrome results in a view indicating there is a problem during compilation in the case of missing resources.

Regards, maha