Plone 5.2.2 soft released

hm ... after brew upgrade libxml2 on my mac and rebuilding lxml==4.5.1 everything worked again ...

==> Upgrading 1 outdated package:
libxml2 2.9.9_2 -> 2.9.10_1
==> Upgrading libxml2 2.9.9_2 -> 2.9.10_1 
1 Like

For those who have tested a Plone 5.2.1 to 5.2.2 migration, can you verify in portal_setup Upgrade tab for plone.staticresources if you have the upgrade step 8 that was done?
I'm not sure if those upgrades are done automatically with the upgrade-plone view or if there is something we need to add in plone.app.upgrade.

Looks good here. I'm at 8

Side note: plone.app.discussion has an upgrade step that was not run.

A new release of plone.app.upgrade would be nice to include https://github.com/plone/plone.app.upgrade/pull/235

1 Like

I added updated versions:

plone.app.content                     = 3.8.4
plone.app.contenttypes                = 2.1.8
plone.app.discussion                  = 3.4.2
plone.app.layout                      = 3.4.3
plone.app.upgrade                     = 2.0.33
plone.app.vocabularies                = 4.2.0
plone.app.z3cform                     = 3.2.1

I've just tested this and it worked.

I have installed as well and I do not remember to have run it manually :slight_smile: So seems to work!

I'm sorry to come up with this edgy edgecase here after upgrading to 5.2.2-pending.

Situation: Tiles on Mosaic pages loose their stored zope.schema.Bool information (always False)

Cause:
Plone 5.2.1 -> plone.jsonserializer serializes the TileData correctly with its plone.jsonserializer.deserializer.converters.bool_converter

Plone 5.2.2 -> the same call of getMultiAdapter([<implementedBy builtins.bool>, <implementedBy zope.schema._bootstrapfields.Bool>], <InterfaceClass plone.jsonserializer.interfaces.ISchemaCompatible>) returns plone.jsonserializer.deserializer.converters.from_unicode_converter

This smells like an issue with the new zope.interface==5.0.2 and I have to investigate more on that ...

/cc @jensens @datakurre

Meanwhile I’m sorry for the whole plone.jsonserializer. It was supposed to be shared with plone.restapi and guillotina (then plone.server), but neither happened. For Mosaic it was supposed to prepare for new editor where layout and tiles could be edited with less backend calls (without plone.tiles query string serializer; with both layout and tile data saved in a single ”content” field).

AFAIKS this has nothing to do with jsonserializer ... the newest version (0.9.9) in Plone 5.2.1 works well but the same version with Plone 5.2.2 returns the wrong adapter ...

pretty weird, but this work for me ... nevertheless it's interesting that the adapter for IBool worked with zope.interface < 5.0 but now the IFromUnicode wins ... zope.schema.Bool implements both ...

2 Likes

Hey, nice work with this one!

Your checklist is correct. I've typically alerted the installers team after the release has been finalized. There are usually a few days between when the release is buildout-ready and when it's officially "released with installers".

Let me know if there's anything I can do to help out.

edit: I just gave you the title, so you're all official here. :wink:

3 Likes

@petschki Do you have a plone.app.discussion upgrade step that was not run too?

no ... all steps are done here:

plone.app.discussion
plone.app.theming
plone.app.staticresources
Products.CMFPlone

portal_setup says all up to date...

Several core packages are in a list of add-ons in the migration tool. When you run a migration (@@plone-upgrade) all packages in this list are checked and any upgrades run. In some cases it makes sense to add an upgrade step in plone.app.upgrade, and in other cases it makes more sense to add it in an individual package. Also: historically grown.

This works well, as far as I know.
But when you have run the @@plone-upgrade, and all upgrade steps are applied, and then you update plone.app.discussion to a newer version that has an extra upgrade step, then there is no code that applies this. Only in this case, do you need to go to portal_setup and check the Upgrade tab.

1 Like

Ah, thanks! :slight_smile:

Added:

plone.app.theming 4.1.2
plone.jsonserializer 0.9.10

Thanks for the explanation @mauritsvanrees about the upgrade. This is less magic now. :slight_smile:
I tested myself a Plone 5.2.1 to 5.2.2 migration on a newly created Plone 5.2.1, no issue to report.

@mauritsvanrees new plone.app.mosaic release 2.2.3 ... can you upgrade those "ecosystem" versions in buildout.coredev 5.2/6.0 branches?

1 Like

Added:

plone.app.mosaic = 2.2.3
zest.releaser = 6.21.0

@petschki When I try both versions of plone.app.mosaic in a customer project I get an error related to the zope.tales/chameleon changes:

http://localhost:8080/be/nl/front-page/@@page-site-layout
Traceback (innermost last):
  Module ZPublisher.WSGIPublisher, line 162, in transaction_pubevents
  Module ZPublisher.WSGIPublisher, line 359, in publish_module
  Module ZPublisher.WSGIPublisher, line 262, in publish
  Module ZPublisher.mapply, line 85, in mapply
  Module ZPublisher.WSGIPublisher, line 63, in call_object
  Module plone.app.blocks.resource, line 284, in __call__
  Module plone.app.blocks.layoutviews, line 41, in __call__
  Module Products.Five.browser.pagetemplatefile, line 126, in __call__
  Module Products.Five.browser.pagetemplatefile, line 61, in __call__
  Module zope.pagetemplate.pagetemplate, line 135, in pt_render
  Module Products.PageTemplates.engine, line 322, in __call__
  Module z3c.pt.pagetemplate, line 176, in render
  Module chameleon.zpt.template, line 299, in render
  Module chameleon.template, line 214, in render
  Module chameleon.utils, line 75, in raise_with_traceback
  Module chameleon.template, line 192, in render
  Module d20d04a54dcd6719f7bdcc421981a243, line 106, in render
  Module 019cf7a3970ab4e7c8123ee7e0e60a90, line 723, in render_master
  Module 019cf7a3970ab4e7c8123ee7e0e60a90, line 1412, in render_content
  Module zope.tales.expressions, line 241, in __call__
  Module Products.PageTemplates.Expressions, line 152, in _eval
  Module zope.tales.expressions, line 140, in _eval
  Module Products.PageTemplates.engine, line 165, in __getitem__
KeyError: 'True'

Have you seen this? Might be specific for a template we have for this customer, I have not checked yet.

Plone Foundation Code of Conduct