Plone 4.3.13 soft-released

I tested 4.3.14-pending in three sites and all seems well.

I wouldn't call the problem a blocker: there is only a problem in tests, and then only for some add-ons, and the problem is already there in 4.3.12 IIUC.
It should be fixed of course, but it's not a blocker in my definition.

I'm ok with that as long as the fix is made available immediately after the release.

currently we've been forced to test against Plone 4.3.11 and plone.api 1.6 and that's far from ideal.

notice that our test setup is good enough to help you discover 2 bugs (HT @idgserpro).

I've pushed 4.3.14 to the released state.

@esteele will you still make the -pending urls available like after the final release? What did you decide after the discussion we had about this topic?

@hvelarde doesn't exist anymore, all packages and buildouts that references buildout.plonetest are now broken. Should they just be changed to

yes, you can change it also:

Thanks for editing. We still think the best approach is to maintain all -pending urls in dist.plone.

I am revisiting a problem I had a year ago with upgrading 4.3.x from an initial 4.3.1 MS installation. I have successfully, over the last two days done the progression from 4.3.1 thru to 4.3.12 but failed migration on 4.3.13 and 4.4.14. (yes I got it to work on MS 4.3.7 and 4.3.8) This upgrade path still uses PY2.6 .... could this be the problem with these last two soft releases?
BTW .... still can't find anyone who uses Plone anywhere near me :frowning: MW. Adelaide, South Australia

You might want to post more details about your migration error. buildout.cfg, error stack, etc.

Re Adelaide, I'm sure they're there but just lurking ...

Hi Kim, buildout.cfg seemed to compile normally
"We have the distribution that satisfies 'unittest2==0.5.1'.
Generated script 'C:\Plone43\bin\run-instance'.
Updating service."

When I did a Dry Run Upgrade, I got the following

Upgrade report

Dry run selected.
Starting the migration from version: 4315
End of upgrade path, main migration has finished.
The upgrade path did NOT reach current version.
Migration has failed
Dry run selected, transaction aborted

Version Overview

Plone 4.3.13
Zope 2.13.24
Python 2.6 (r26:66721, Oct 2 2008, 11:06:43) [MSC v.1500 64 bit (AMD64)]

I have no other pointers to the problem.
Best wishes

Doing a 'dry run' means that Plone is going to run all code that it would normally run, but at the end it will abort all changes. After aborting, the version is still the same, so you get this message. If this is the only error that you see, then it really means that the dry run is successful. If you do the real migration instead of a dry run, it should work fine.

I have see this question before. Is the term 'dry run' maybe not as well known as we think? Or should we improve the message after the dry run? I guess the code should be able to see that the only reason the migration 'failed' is because it was a dry run, and could say something more helpful.

Thx Maurits

This is being done on a vanilla install
BUT 4.3.13 is the 1st example in the run up from 4.3.1 through to 4.3.12 that DID NOT complete the Dry Run without a positive end point.

It's an anomaly, but happy to try it tomorrow.
Best wishes

Seems like a good idea :slight_smile:

@IntranetGWT please post the full text of the upgrade messages you got. Also your full buildout.cfg

Hi Kim & Maurits - I tried the upgrade without the "dry-run" and am left with no ability without going back to my backup and reinstalling 4.3.12 - the screen captures and buildout.cfg for 4.3.13 is too big to possibly put here. What was the name of the site that I could apply the code and get a simple link to give to you both. Rgds Michael

Are you saying it damaged your site? Can you get to the ZMI's undo tab? is a service you could use.

That's the one .... but is currently down - will send asap
This was purely done on a Vanilla site - no data damage -

Lots of other similar services. Try

Sorry didn't like the way pastebin wanted to tack onto my contacts

Found and have used Ghostbin

I can send the graphics that were generated when the load failed if need be.

I'm just reading the Plone training manual for 4.3 @ and note the transfer Python 2.6 to 2.7 though the 4.3 development process. Just wondering whether this is a cause for my migration problem (Microsoft) upgrade failure from 4.3.13 ... Just a thought