Ordered list in other formats beside numbers are not showing up properly

Hi,

I am trying use a numbered list in Plone. However, when I use lower alpha or anything else, it always display the list as a numeric list.

This is what show ups in the edit window:

  1. Line 1
    a. Line 1.1
    b. Line 1.2
  2. Line 2
    a. Line 2.1
    b. Line 2.2
  3. Line 3

When I hit save, the following shows up:

1. Line 1
    1. Line 1.1
    2. Line 1.2
2. Line 2
    1. Line 2.1
    2. Line 2.2
3. Line 3

Does anyone know how to get other formats beside numbers in a numbered list to work? Any help would be appreciated. Thanks so much.

Plone version:

Plone 5.1.0.1 (5110)
CMF 2.2.12
Zope 2.13.26
Python 2.7.12 (default, Dec 4 2017, 14:50:18) [GCC 5.4.0 20160609]
PIL 4.3.0 (Pillow)

Possibly a TincMCE problem. When you mark the second level list as greek alpha then it shows up as greek alpha. Open "View source" and you won't see any related CSS classes which I would expect here. Close "View Source" and the greek alpha has gone...so it appears like a complete client-side problem and I would possibly blame TinyMCE here.

Is there a solution to this problem or is this a known issue that has yet to be resolved?

Look through the TinyMCE bugs or as the TinyMCE guys.

This is a html filtering problem
I did a test an disabled filtering at:
/@@filter-controlpanel

works for me,
Probably 'type=' is being removed

By the way: in my setup, it shows correctly in the editor, but not after save

I wonder why HTML filtering takes place client-side too...this was always a server-side only functionality?!

Anyway...when you disable HTML filtering completely then the TinyMCE shows the dedicated CSS class and the content can be saved and displayed properly (tested with Plone 5.1.2.1 on plone-demo.info).

It is clearly a bug or a bad plone default configuration for TinyMCE not defining the associated CSS attributes as allowed in the default HTML filtering settings -> please file a bug report for this.

31-13-12-58

Thanks Espen. Yes, before I disabled HTML filtering, I tried to add "type" as a valid tag and as a allowable custom tag and in both cases it failed. You are right. Only when I disabled filtering did it work. Thank you so much!

Andreas, I am trying to report this as a bug. Is this where I report it?

If so, should I report it under buildout.coredev or a Products.CMFPlone? Is it the latter? Please advise.

Thanks!

I filed the bug report already for you

Andreas, you are awesome! Thanks so much!

I did this in the control panel, and now it seems to work (but no idea what the correct setup should be):

Epsen, this is awesome! Yes, I did exactly what you recommended and uncheck Disable HTML filtering while I was at it It is working perfectly! Thanks so much!!!