Not using as default?

Let me note that we already have nearly all the problems that have been mentioned as a negative for replacing Everyone that is checking out an old buildout or trying to update an old site is running into the fact that is broken without extraordinary workarounds.

So, we already need to do some documentation to help these poor souls out of their bootstrap/setuptools hell. At the moment, it looks easiest to me to document the virtualenv/buildout approach.


I've just found time to come back & read this. I want to say thanks to Jens - for the virtualenv idea & everyone for the very helpful open discussion. I think the best thing that can be put in the docs is a clear admission that this area gets difficult at times... that should keep new adopters with us, rather than giving up!

Btw yesterday I found the following command which seems like it would help with version conflicts when I get them (is this obvious, or not?) In this example for plone.resource, it shows me what other products require it & what pins they apply:

$ grep plone.resource  eggs/*.egg/EGG-INFO/requires.txt 

Worked fine for a while but ...


I think this was solved meanwhile.

Indeed, imissed to pin plone.recipe.zope2instance to 4.4.0 (was 4.3)
Sorry ....

@jensens :+1:

I has been many nightmares trying to fixed the correct pinnies for setuptools or zc.buildout packages every son often, because my file is outdated.

I'm not having problems for a while. The last version is on (it's hasn't been updated recently though).

For people coming just now about the discussion, don't forget to check

You can even skip step one and do bin/pip install -r