No module named processlifetime

I have an (old) plone 5 site that suddenly would not start anymore. Nothing was done on purpose (but I ran buildout again to try to get it up again), but note that I have other sites running new(er) Python.

Any suggestion on how to sort this out (install just for 2.7) ?

  /instance8015/zinstance$ bin/instance fg
  Traceback (most recent call last):
   File "/path/to/instance8015/zinstance/parts/instance/bin/interpreter", line 342, in <module>
	 exec(compile(, __file__, "exec"))
   File "/path/to/instance8015/buildout-cache/eggs/Zope2-2.13.26-py2.7.egg/Zope2/Startup/", line 76, in <module>
   File "/path/to/instance8015/buildout-cache/eggs/Zope2-2.13.26-py2.7.egg/Zope2/Startup/", line 17, in run
	 import Zope2.Startup
   File "/path/to/instance8015/buildout-cache/eggs/Zope2-2.13.26-py2.7.egg/Zope2/", line 60, in <module>
	 from import configure
   File "/path/to/instance8015/buildout-cache/eggs/Zope2-2.13.26-py2.7.egg/Zope2/Startup/", line 28, in <module>
	 from zope.processlifetime import ProcessStarting

bin/pip2.7 install zope.processlifetime
Requirement already satisfied: zope.processlifetime in ./lib/python2.7/site-packages (2.3.0)
Requirement already satisfied: setuptools in ./lib/python2.7/site-packages (from zope.processlifetime) (40.2.0)
Requirement already satisfied: zope.interface in ./lib/python2.7/site-packages (from zope.processlifetime) (5.4.0)

Might be a circular import. I suggest to temporarily edit Zope2-2.13.26-py2.7.egg/Zope2/Startup/ and put import pdb; pdb.set_trace() before the line that imports from zope.processlifetime. Check if the package is available, should be similar to this (but different version):

>>> import pkg_resources
>>> pkg_resources.get_distribution("zope.processlifetime")
zope.processlifetime 2.3.0 (/Users/maurits/shared-eggs/cp27m/zope.processlifetime-2.3.0-py2.7.egg)

If this works, then with pdb step into the import and see where it fails.

I installed the same versions (with Universal installer) and 'moved database/everything'. Since this worked I have not tried to figure it out why yet (and it is a 'school site', so they are still 'on holiday'.