New portfolio built using Plone mosaic

Hey @datakurre, @sgrepos, @cewing, @tkimnguyen,

Finally, I just deployed my new portfolio using Plone mosaic and Digital Ocean (it also replaced my old portfolio, which was built using Wordpress). It can be found at http://chautunglamnguyen.me/ .
I just want to thank you guys for giving me feedback and suggestions. It took me a while to deploy this but it was a fun learning experience. I also documented every step I took so that I can remember things easier. Please let me know if there is any mistake in my notes (I learned taking notes from my mentor).
Of course there are still a lot of things to work on, and I will keep taking notes on what I have done to learn more effectively.
Thank you guys.

2 Likes

Nice work @nctl144, loads faster this time around too! :thumbsup:

Your page at http://chautunglamnguyen.me/info/deploy-plone-to-digital-ocean says DigitalOcean's $10/mo. is the smallest package Plone can run on, but my understanding was it could run on DigitalOcean's 512 MB $5/mo. plan too after reading the requirements at https://docs.plone.org/manage/installing/requirements.html#hardware-or-virtual-environment-requirements. :confused:

Yeah I know but when I tried the $5/month plan, I couldn't run the installer. But when I upgraded it to 10$/month plan, the installer ran normally. It's just based on what I have been through lol...

@nctl144 Oh I see, thanks for letting me know!

What was the error or problem with the installer on the $5 plan? Out of memory?

By the way Plone 5 runs on a first generation Raspberry Pi...after 7 months you'll be ahead relative to a $5 plan :slight_smile:

1 Like

And if you front your Raspberry Pi site with CloudFlare you'll get fast performance even if it's sitting in your home. :slight_smile:

@tkimnguyen When I tried to run the installer with the 5$ plan, it just reported that the installation failed and it couldnt install lmxl 3.5.0 and the installation exit with the error code 4. That is all I remember. Then I searched on Google and they said it was because of the plan that I was using. So I switched to the 10$ plan and it worked.
Hmm, the Raspberry Pi sounds interesting. Can you give me more information about it (documentation) so I can learn more. Probably I am going to use it for the Plone sites I am building in the future.

Thanks for documenting your steps. Possibly your notes could be polished into a maintained part of our documentation? @svx what is the current license of our docs? Should deployment be part of normal docs or training docs?

The good thing in 10$/mo plan is that you have space for performance optimisations like caching proxy (e.g. Varnish) :slight_smile:

That said, would cloudflare be good enough for caching public Plone-pages?

To answer myself, cloudflare seems to implement its own purge API (as a REST API), which is currently not supported by plone OOTB.

I am more than happy to be able to contribute to the Plone documentation :). I also know some of the errors that people might have during the deployment process and I can document more about those (as well as how to fix those issues).
From now, probably I will learn more about caching and modifying the theme to improve the site (I will take note too)
Until now, I think this VPS plan on Digital Ocean is pretty good and I like using it so far. But probably I need to learn more about Cloudfare and use it to suggest the best methods for deployment.

1 Like

I'm using D.O. with the 5$ some time to deploy test Plone sites or to show some stuff to clients.
It works well.
But i was using the ansible.plone_server to deploy the sites to D.O. which is white good and i can recommend this way.

[EDIT] I'm using it with Debian or Ubuntu :wink:

1 Like

I will try using ansible and add more methods to deployment :slight_smile: For the Unified Installer, I ran into a lot of problems while running the installation. For example:

Getting distribution for 'lxml==3.5.0'.
x86_64-linux-gnu-gcc: internal compiler error: Killed (program cc1)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-5/README.Bugs> for instructions.
/tmp/easy_install-2kIfB2/lxml-3.5.0/temp/xmlXPathInitjW78Bn.c:2:1: warning: return type defaults to ‘int’ [-Wimplicit-int]
 main (int argc, char **argv) {
 ^
Building lxml version 3.5.0.
Building without Cython.
Using build configuration of libxslt 1.1.28
Compile failed: command 'x86_64-linux-gnu-gcc' failed with exit status 4
error: Setup script exited with error: command 'x86_64-linux-gnu-gcc' failed with exit status 4
An error occurred when trying to install lxml 3.5.0. Look above this message for any errors that were output by easy_install.
While:
  Installing instance.
  Getting distribution for 'lxml==3.5.0'.
Error: Couldn't install: lxml 3.5.0

Hey @datakurre, since you mentioned it, I think it might be a good idea to add suggestions for specific deployment methods (services people should use to test deployment such as Digital Ocean or Cloudfare) and the common errors that people might get into while installing Plone. Since it took me a few days to do that simple task, I hope that I can save people's time by making the documentation more specific. I just want to know how to get started on it. Do you have any reference or something that I can get to know more about it? (workflow or something like that) I want to get started in this as soon as possible :slight_smile:
I have signed the contributor agreement :slight_smile: so I think I should be good to go right?

@tkimnguyen I just got the same lxml error as @nctl144 during installation on DigitalOcean's $5/mo. 512 MB plan. But I also confirmed that Plone 5 can still run on DigitalOcean's $5/mo. 512 MB RAM plan. You just need to resize your droplet to the $10/mo. 1 GB RAM plan to install Plone first, and then you can resize it back to the $5/mo. 512 MB RAM plan. :slight_smile:

2 Likes

And now, the $5/mo comes with 1GB Ram and 25GB storage!

1 Like