LDAP addon not showing up

I'm looking for a push in the right direction.

I am trying to implement LDAP and I am using Products.PloneLDAP on Plone 5.

My buildout.cfg looks like this:

eggs =

When I run bin/buildout the output shows the following:

Products.LDAPMultiPlugins = 1.14
Products.LDAPUserFolder = 2.27
Products.PloneLDAP = 1.2
dataflake.fakeldap = 1.1
plone.recipe.command = 1.1
plone.recipe.precompiler = 0.6
python-ldap = 2.4.25

However, when I reload Plone and then navigate to Site Setup/Add-ons there is no LDAP addon to install or activate. Am I missing something?

Any assistance is appreciated.

You have probably installed a package that works on Zope level, you don't have to install anything in Plone and you don't have any Plone UI.
Go to ZMI -> acl_users and add an LDAP multiplugin from the top right menu

Final note: evaluate a switch to plone.app.ldap (not sure if is already Plone 5 compatible): it will give you Plone installation and Plone UI.

Hi Luca

Thank you for the reply. That was very helpful. I tried to use phone.app.ldap but Plone 5 crashes. Using Products.PloneLDAP, I am able to authenticate but I find authenticated users do not have the navigation menu on the left. There is no navigation other than "Home".

Missing navigation might have to do something with the default role authenticated LDAP users get from the pluging and your site setup.

This is I think a setting in the ldap plugin in the acl_users folder, you could change this to Member instead of Authenticated.

That helped. Thank you. In the acl_users there is a default role and it was set to anonymous. It is working. Thank you Fred and Luca.