When Plone 4 shipped, jquery 1.7 was included by default and this is still the case for the core distribution. Efforte by @thet and others 1-2 years ago made Plone compatible with jQuery 1.9 and when we did upgrades/new themes the recent years as an integrator we pinned jquery at least to 1.9 to benefit from jquery bugfixes.
From a frontend developer I recently talked to I understood that the jquery 1.X series updates after 1.9 were indeed bugfixes and no incompatibilities/problems should arise. For others who follow the same practice: last week I found out jquery 1.11.3 is the last version you can safely update to. (and avoid 1.10.1, tinymce's plonebrowser will not work with that one)
In jquery 1.12.x a function .buildFragment has been made private and the overlayhelpers.js (.prepOverlay() in plone.app.jquerytools that's shipping with Plone 4 depends on that function.
The motivation for privatising the function in the jquery 1.X branch is a bit odd where it is argued 'now is the time to do it for jquery 3.X and it wasn't part of the public api". So why break compatibility with for 1.X users, but well...
I tried to look up if other projects that depend on jquery have had the same problem and possible solutions, found one (https://github.com/canjs/canjs/issues/2176) but I'm a (beginning) jquery user, no clue about the internals and the changeset there didn't help me.
So for now, if you prefer a recent jquery in your Plone 4 projects, stick with 1.11.3 if you or your addons need .prepOverlay. And if you're a jquery wizard....