[JENKINS ANNOUNCEMENT] replace Jenkins master server

Hi all,

today, sorry for the short notice, the server that powers the UI interface of jenkins.plone.org will be not consistently reachable between 22:00 and 23:00 Berlin timezone (note the daylight save):


The current server contract is being cancelled at the end of the month and @tisto will stop paying for it and instead all of us, i.e. the Plone Foundation, will be paying for the new server.

Thanks to @tisto for paying the server for so many years, and thanks for the Plone Foundation for stepping up and paying the bills from now on! :clap:


Jenkins is up and running again, as usual, with these kind of servers that have LOTS of configuration and tweaks, one or two things had to be amended, but overall seems that it should be working fine already.

Please, file issues on jenkins.plone.org github repository or write here if you encounter problems using jenkins.plone.org, otherwise, happy hacking!

I reply to myself :rofl:

I need help: Jenkins can not send any email as the password (fortunately) is stored encrypted on the old jenkins, and I have no idea about it.

Whoever knows the password for jenkins@plone.org to authenticate to smtp.gmail.com, please contact me :smile:

@gforcada great work! thank you very much!

I just tried to test a PR (with two URLs) and got this on the console ... do you have an idea what's going wrong here?


Is the 6th birthday of my older daughter, I will have a look at night if
you don't mind :smiley:

El dt., 2 abr. 2019, 4:08 p. m., Peter Mathis community@plone.org va

Not at all! Happy Birthday first of all :tada:

I think the main problem of this is, that jenkins has no authorization to the /zopefoundation organization (see PR https://github.com/zopefoundation/plone.z3cform/pull/25#issuecomment-479405587) and could not complete the build here even though the tests pass all (https://jenkins.plone.org/job/pull-request-5.2/12/console) ... I think the quickest solution in order to get the plone.app.caching PR green is to merge and release plone.z3cform on zopefoundation ... this package really need to be moved to /plone organization ... but thats out of scope here ...

thank's again and party on!

Yes, that seems to be the issue, the question though, is that it was like that before as well, so not a problem of the new system.

I created a ticket on jenkins.plone.org repo:

1 Like

That's already solved, thanks to @esteele :+1: