Issue using Plone Poll

I am using Plone 5.0.8

  1. I installed collective.polls. Installed properly. Tried to create a poll (not a porlet) but got an error (don't have the error text).

  2. I deactivated poll on my site.                  
  3. i found
    So, I pinned (collective.polls = 1.10b1) , ran buildout. v 1.10b1 shown as installed.

  4. poll showed in add tools. I tried to activate, but got this:

Traceback (innermost last):
Module ZPublisher.Publish, line 138, in publish
Module ZPublisher.mapply, line 77, in mapply
Module ZPublisher.Publish, line 48, in call_object
Module Products.CMFPlone.controlpanel.browser.quickinstaller, line 227, in call
Module , line 3, in installProducts
Module AccessControl.requestmethod, line 70, in _curried
Module Products.CMFQuickInstallerTool.QuickInstallerTool, line 686, in installProducts
Module Products.CMFQuickInstallerTool.QuickInstallerTool, line 602, in installProduct

  • traceback_info: ('collective.polls',)
    Module Products.GenericSetup.tool, line 388, in runAllImportStepsFromProfile
  • traceback_info: profile-collective.polls:default
    Module Products.GenericSetup.tool, line 1433, in _runImportStepsFromContext
    Module Products.GenericSetup.tool, line 1245, in _doRunImportStep
  • traceback_info: cssregistry
    Module Products.CMFPlone.resources.exportimport.cssregistry, line 16, in importCSSRegistry
    Module Products.CMFPlone.resources.exportimport.resourceregistry, line 36, in importResRegistry
    Module Products.GenericSetup.utils, line 512, in _importBody
    Module Products.CMFPlone.resources.exportimport.resourceregistry, line 163, in _importNode
    Module Products.CMFPlone.resources.browser.cook, line 139, in cookWhenChangingSettings
    Module Products.CMFPlone.resources.browser.combine, line 142, in combine_bundles
    Module Products.CMFPlone.resources.browser.combine, line 91, in write_js
    Module, line 158, in writeFile
    Module OFS.Image, line 139, in init
    Module OFS.Image, line 544, in _read_data
    Module transaction._manager, line 101, in savepoint
    Module transaction._transaction, line 260, in savepoint
    Module transaction._transaction, line 257, in savepoint
    Module transaction._transaction, line 690, in init
    Module ZODB.Connection, line 1125, in savepoint
    Module ZODB.Connection, line 623, in _commit
    Module ZODB.Connection, line 658, in _store_objects
    Module ZODB.serialize, line 422, in serialize
    Module ZODB.serialize, line 431, in _dump
    PicklingError: Can't pickle <class 'collective.z3cform.widgets.interfaces.ILayer'>: import of module collective.z3cform.widgets.interfaces failed

any ideas?

Apparently, you must install collective.z3cform.widgets (add it to your buildout.cfg).

versions before 1.9b1 are not compatible with Plone 5; the issue you're experiencing it's explained clearly on the changelog:

so add collective.z3cform.widgets to your buildout and try uninstalling it (I don't know if it will work).

please use the issue tracker to report any bug and not this forum.

Hi, this is correct.

however, when you look at Github:
there is no mention. It talks about pinning but only for 4.2. I thought github was now the preferred location for code and that is where i go first.

thanks for your comments. Here is what I found confusing:

I installed Poll first as described above. In addition to Poll being installed it automatically picked some other requirements. z3cform I think was one. they showed up in the "Add". I added poll and these new products.

When i tried to use Poll, I got the issue as described above.

So i created a clean installation of Plone 5.0.8, installed Poll 1.10. Installed smoothly, but without the other products. Don't know why.

I tried Poll on this new installation, and it worked fine.

I don't know if this is of any interest; however, I thought I close the loop and let others know.

because, as you can read on the changelog, we removed the dependency on that deprecated package.

collective.polls, as well as other products we release for the public, are mainly oriented to our own consumption; if I had resources I could dedicate more time to polish them, including the documentation, but it's the same old story.

I know the documentation is far from optimal, but writing a small user's guide, or reviewer's guide, is something you can help on.

Hi, wasn’t implying there was something wrong with your effort or asking you to do anything for me. I figured it out and see Poll does what is advertised. Thanks.

I, and the community, appreciate the code that you and others release. I always figured my role in helping, as a user and sys admin, would be to let developers and the community know issues that I found and determine if they were code issues or user errors. If it is a bug, I have on many occasions filed a bug report. Sometimes this is well received, sometimes not.

As for reporting issues in bugs vs. posting here, this has always been something that confused me. I post here when I'm not sure it's a bug vs. something I'm doing wrong. This allows me to get expert advice and for all Plone users to see the issue and learn.

1 Like

you're doing a great work, thanks!