Inserting images in non english sites wont work


i am using Plone 5.0.4 and when i create a new site with english language it is no problem. But when i create a site, at least in german, i am not able to select an image to insert it with the TinyMCE Editor. I am able to browse the directories and i see the image files, but when i click on it the image could not taken. Switching to english in the language settings solves this behavior.

I can confirm this bug.

Possibly related to missing TinyMCE JS files.

default.js:5 GET 404 (Not Found)

Please file a bug report with the Plone bugtracker on Github.


I think this is solved already. There are several the same or similar issues in the tracker that have been closed.
For example this one:
It might be solved with 3.1.1. So you can try to update this single package in your buildout, or wait until Plone 5.0.5 is out, which should be 'soonish'.

1 Like

Here are the other similar isssues:

Yes, Pin the Version in buildout.cfg to = 3.1.1

Thank you for your replies ...

I try to update to = 3.1.1 and for a new created site it works fine :wink:
But on the existing site i cant display the content-tab anymore after the update and got this error

Traceback (innermost last):
  Module ZPublisher.Publish, line 138, in publish
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 48, in call_object
  Module, line 275, in __call__
  Module, line 233, in get_options
  Module, line 65, in get_top_site_from_url
  Module ZPublisher.HTTPRequest, line 280, in physicalPathFromURL
ValueError: Url does not match virtual hosting context

Switching back to = 3.0.20 solve the problem on this site...

I estimate this happend because i switched the language several times from en to de ... or something like that

I will try to find some more information or logs on an other testing instance of Plone 5

Maybe the next minor update to 5.0.5 will fix it ...

Backup 1st, but you can already test 5.0.5 soft release by updating your buildout.cfg to

Plone 5.0.5 is out now. (Installers will follow, but the versions are here:

Ok, thx
In 5.0.5 it works fine now :slight_smile: