Image editor for Plone 5.1

We are planning to migrate our Plone4 site to Plone5.1. Is there product similar to Products.ImageEditor for plone5.1 ?

Thanks
R.

1 Like

I don't think so.

You could probably get it to work if you keep on using Archetype Images (but that does not sound as a good idea).

You might want to take a look at these add-ons, at least if it you need 'cropping/resizing':


Hi, I am using plone 5.0.8 which has plone.namedfile-3.0.11-py2.7.egg. When I tried to install plone.app.imagecropping add-on, the bin/buildout run said:

Version and requirements information containing plone.namedfile:
[versions] constraint on plone.namedfile: 3.0.11
Requirement of plone.app.imagecropping: plone.namedfile>=3.999
While:
Installing instance.
Error: The requirement ('plone.namedfile>=3.999') is not allowed by your [versions] constraint (3.0.11)

What should I do to upgrade the plone.namefile version to 4 or newer?
Could someone give me a hint. please?

Sometimes, the versions of an add on is important.
In your case, with plone.namedfile, no harm will probably happen if you use a newer (probably it is better).

EDIT: I now see that versions higher than 4.0 is for Plone 5.1 only (so you will need to upgrade Plone to use this add on (or at least this version of the add on)

So
Open your versions.cfg and change the line with:

plane.namedfile

to

plone.namedfile>=3.999

Actually; you can probably change it to 4.2.4, check the change log here:

If 'you can still not get it to work', you can pin your versions in buildout.cfg (at the end). Just notice that the syntax is a little different (if it is plone.namedfile == 4.2.4 in versions.cfg, it is plone.namedfile = 4.2.4 in buildout.cfg.

Dear espenmm,
Sorry for I have lost for a while, out of the town. Many thanks for your suggestions. I have changed the line of
plone.namedfile in the versions.cfg to
plone.namedfile = 4.2.4
and run the $ bin/buildout command, following your guide. There is still an error as follows:

Getting distribution for 'plone.namedfile==4.2.4'.
warning: no previously-included files matching '*.py[co]' found anywhere in distribution
Got plone.namedfile 4.2.4.
Version and requirements information containing products.cmfplone:
[versions] constraint on products.cmfplone: 5.0.8
Requirement of plone.app.imagecropping: Products.CMFPlone>=5.1.a1
Requirement of Products.PloneFormGen: Products.CMFPlone>=5.0b2.dev0
Requirement of Plone==5.0.8: Products.CMFPlone
While:
Installing instance.
Error: The requirement ('Products.CMFPlone>=5.1.a1') is not allowed by your [versions] constraint (5.0.8)

I still don't know how to solve it. Seems that I have to upgrade to plone 5.1. Is that possible?

Do I need to change the Products.CMFPlone in the versions.cfg file from 5.0.8 to
Products.CMFPlone =5.1 ?

I did change the Products.CMFPlone = 5.0.8 in the versions.cfg file to

Products.CMFPlone = 5.1.a1

and run the bin/buildout and get following errors:

Got Products.CMFPlone 5.1a1.
Getting distribution for 'piexif'.
Using unpack_wheel() shim over the deprecated wheel_to_egg() hook.
Please update your wheel extension implementation for one that installs a .whl
handler in zc.buildout.easy_install.UNPACKERS
While:
Installing instance.
Getting distribution for 'piexif'.
Error: Wheels are not supported

You could upgrade to the latest Plone version (5.1.rc2 at the moment), but this is not stable. The latest stable is 5.0.8, which you are using.

The latest compatible version of plone.app.imagecropping with Plone 5.0.8 is 2.0b3. I would use this for now.

Dear tmassman,
Many thanks for your suggestions. I did add

plone.app.imagecropping = 2.0b3

into the [versions] section of the buildout.cfg file and run the $ bin/buildout

Got the instance of this buildout. Hope it is alright. Thanks again tmassman.