How can i install 5.2 on heroku account

I have a heroku account and would like to install 5.2 for test.

Here: https://plone.org/download it says i can install 5.1.4 on Heroku. is there a way to install 5.2 instead?

thanks.

It uses http://github.com/collective/training-sandbox which was updated by @witek to use 5.1.5 but I forgot to update the page.

Depending on how comfortable you are with poking at it, it probably isn’t hard to update a branch of the repo to use 5.2 and have your Heroku account use it for a new deployment. But it would probably be more work to get 5.2 and Python 3

Use the demo.plone.org site if you just want to try out 5.2

Thanks @tkimnguyen I wanted to test one of the standard plone themes listed here: https://plone.org/download

i tried uploading the zip but got an error because the size was too large. I'll wait until the programmer returns from vacation and have him create an instance for me.

Perhaps the demo site could be updated to have one or more of the themes uploaded by the admin so testers could go into the theme panel and switch between them. this would provide valuable testing for the themes.

When I last tested these themes, only one worked well with Plone 5.1.5 so someone will need to update them for 5.1.5 and 5.2.

The intent of demo.plone.org is to let people test Plone out of the box. It would be quite some effort to have it include add-ons, because those add-ons would have to be tested for compatibility first, and we’d be opening up a can of worms regarding which add-ons get included or not. If someone has the time and energy to set something up that does this and is willing to maintain it, then please let us know!

The Heroku deployment option is also meant as a simple demo, so you would have to tweak it to allow big uploads.

@tkimnguyen Thanks for the explanation. I now understand how my "simple" request would result in more work for the volunteers.

Thx for understanding @rileydog but all good things start as ideas so if you were to take on a portion of that (eg just organizing a thing and calling for volunteers) it could very well happen. Sometimes all it takes is for someone to call attention to a thing, so thank you.

fix the 5 themes to work with Plone 5.1.5 and 5.2
add tests to the themes so we can use CI to determine if they are rendering correctly
add CI to run the tests to ensure that the themes work with all new releases of Plone
ensure that CI-reported errors with the themes are reported to individuals willing to make fixes quickly
figure out how to disable or not include a broken theme in demo.plone.org buildout
add themes to the demo.plone.org buildout
add instructions on demo.plone.org explaining how to try out the themes

Looking ahead, when we release Plone 6 and have Volto as the new default UI, these themes are going to be useful only if someone enables the classic Plone UI.

It takes a lot of energy to make new Plone releases, so someone else not already involved in that would be best suited to taking this on.

I just checked and the Heroku deploy button actually uses Plone 5.1.5, because @witek had updated https://github.com/collective/training-sandbox to do so ~6 months ago and I had neglected to update the https://plone.org/download page until just now.

Future Imperfect is the one that works very nicely with 5.1.5 ... and 5.2! It's running on wave.oshcom.net (work in progress), with Plone 5.2 on Python 3.

I am testing the theme from @espenmn testing his theme as I hope to use it on my site. He has it running on 5.2. Once my site is upgraded to 5.2 i want to try it there.
Once I have my test site on 5.2 I will test some of the free themes.

Update:
http://github.com/collective/training-sandbox now uses 5.1.6

I did attempt it to update it to use 5.2, work in progress here:


however I'm currently getting this groovy setuptools related error

Got plone.app.uuid 2.0.0.
Getting distribution for 'decorator==4.4.0'.
warning: no files found matching 'README.rst'
warning: no files found matching 'documentation.pdf'
Got decorator 4.4.0.
Getting distribution for 'jsonschema==3.1.1'.
/usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'use_scm_version'
  warnings.warn(msg)
zip_safe flag not set; analyzing archive contents...
jsonschema.tests.test_validators: module references __file__
jsonschema.tests._suite: module references __file__
jsonschema.benchmarks.issue232: module references __file__
While:
  Installing instance.
  Getting distribution for 'jsonschema==3.1.1'.
An internal error occurred due to a bug in either zc.buildout or in a
recipe being used:
Traceback (most recent call last):
  File "/tmp/build_9022f7bb1c1237ac73bafeaecfe137b2/eggs/zc.buildout-2.13.2-py2.7.egg/zc/buildout/buildout.py", line 2174, in main
    getattr(buildout, command)(args)
  File "/tmp/build_9022f7bb1c1237ac73bafeaecfe137b2/eggs/zc.buildout-2.13.2-py2.7.egg/zc/buildout/buildout.py", line 817, in install
    installed_files = self[part]._call(recipe.install)
  File "/tmp/build_9022f7bb1c1237ac73bafeaecfe137b2/eggs/zc.buildout-2.13.2-py2.7.egg/zc/buildout/buildout.py", line 1603, in _call
    return f()
  File "/tmp/build_9022f7bb1c1237ac73bafeaecfe137b2/eggs/plone.recipe.zope2instance-6.3.0-py2.7.egg/plone/recipe/zope2instance/recipe.py", line 145, in install
    installed.extend(self.install_scripts())
  File "/tmp/build_9022f7bb1c1237ac73bafeaecfe137b2/eggs/plone.recipe.zope2instance-6.3.0-py2.7.egg/plone/recipe/zope2instance/recipe.py", line 782, in install_scripts
    requirements, ws = self.egg.working_set(['plone.recipe.zope2instance'])
  File "/tmp/build_9022f7bb1c1237ac73bafeaecfe137b2/eggs/zc.recipe.egg-2.0.7-py2.7.egg/zc/recipe/egg/egg.py", line 87, in working_set
    allow_unknown_extras=bool_option(buildout_section, 'allow-unknown-extras')
  File "/tmp/build_9022f7bb1c1237ac73bafeaecfe137b2/eggs/zc.recipe.egg-2.0.7-py2.7.egg/zc/recipe/egg/egg.py", line 168, in _working_set
    allow_unknown_extras=allow_unknown_extras)
  File "/tmp/build_9022f7bb1c1237ac73bafeaecfe137b2/eggs/zc.buildout-2.13.2-py2.7.egg/zc/buildout/easy_install.py", line 957, in install
    return installer.install(specs, working_set)
  File "/tmp/build_9022f7bb1c1237ac73bafeaecfe137b2/eggs/zc.buildout-2.13.2-py2.7.egg/zc/buildout/easy_install.py", line 730, in install
    for dist in self._get_dist(req, ws):
  File "/tmp/build_9022f7bb1c1237ac73bafeaecfe137b2/eggs/zc.buildout-2.13.2-py2.7.egg/zc/buildout/easy_install.py", line 574, in _get_dist
    dists = [_move_to_eggs_dir_and_compile(dist, self._dest)]
  File "/tmp/build_9022f7bb1c1237ac73bafeaecfe137b2/eggs/zc.buildout-2.13.2-py2.7.egg/zc/buildout/easy_install.py", line 1776, in _move_to_eggs_dir_and_compile
    assert newdist is not None  # newloc above is missing our dist?!
AssertionError
 !     Push rejected, failed to compile Plone app.
 !     Push failed

Not sure what's up there at the moment.
My latest semi-educated guess was to bump these two packages to the latest versions:

setuptools = 41.6.0
jsonschema = 3.1.1 
1 Like

Plone Foundation Code of Conduct