"Home" tab not translated

  • Context:
    • Linux Mageia 7
    • Plone-5.2.0-UnifiedInstaller
  • Problem: After upgrading a Plone site from 5.1.5 to 5.2, the "Home" tab is (the only one to be) not translated.

To which language?

It translates to Norwegian and Dutch (for me)

Sorry to not have specified it: French. But the .po looks OK: "Home" is translated (in "Accueil").

BTW, it happens also with a fresh, new, empty Plone 5.2 site.

And there are other strings not translated, for instance:

  • the generic "Save" and "Cancel" buttons,
  • "Use portal default" (ATContentTypes/lib/constraintypes.py:40), though it is translated in atcontenttypes.po.

I have to 'take back' what I said.
I use a custom navigation.
I see that the default menu is not translated (maybe because there is a new menu in Plone 5.2).

Note the difference between the breadcrumbs and the tab in the screenshot.

Update: Note also that if you add

          <li i18n:translate="">Home</li>

to sections.pt it gets translated correctly.

Where do you add this line? What I see currently when I add this line is an extra "Accueil" word, not the expected tab ("Home") replaced.

The home tab comes from 'portal_actions'.
This means.

For a single language site, you can work around this by going to the actions-controlpanel and change the text for 'home'.

For a multi-language site, you could remove the 'home'-action and manually add a <li> to sections.pt. (you will need to add a CSS class and a line or two of CSS if you want it to display differently when selected.

That it is not translated is a bug, and if you need to track it down you will need to find out where (and how) the <replace structure part in sections.pt comes from.

1 Like

Thanks for the actions-controlpanel trick: I'd probably won't look at it!

About the bug, I would feel much more comfortable in reporting it than tracking it down :grinning: But I'm not sure what's the best place for reports of such bugs.

Plone Foundation Code of Conduct