Having trouble installing two products

I have two products that I've installed numerous times on Plone 5.0.x they are: collective.portlet.embed and webcouturier.dropdownmenu. Simply added the egg and worked.

However, yesterday they both stopped working during buildout. I got:

Couldn't find index page for 'collective.portlet.embed' (maybe misspelled?)
Getting distribution for 'collective.portlet.embed'.
Couldn't find index page for 'collective.portlet.embed' (maybe misspelled?)
Installing instance.
Getting distribution for 'collective.portlet.embed'.
Error: Couldn't find a distribution for 'collective.portlet.embed'.
[mckennariley@web540 zinstance]$

both are valid products:

Any ideas?

Something has gone wacky. I also can't install mosaic.

I use the same buildout entries that worked a few days ago.

Note: I'm having this issue with two different Plone accounts (although on same host).

Check out the thread here. It’s a general buildout / pypi problem

@tkimnguyen I had seen that. I didn't think it applied because the products I was trying to get weren't on pypi , it was on github. Obviously I don't understand fully the magic of buildout. >)

I read the thread, but I can't tell what if anything a user can do now? It looks like they're trying to fix it, but it isn't something I understand.

Maybe try the last fix posted in that thread