Errors while running the "make" command in "plone-react/api"


I have pulled plone-react, installed the proper node version, installed all the dependencies using Yarn.
When I am running the "make" command (with sudo, so no problem with the privileges), There is one major error that always shows up, "SyntaxError: 'return' outside function", This means there is some problem with the indentation in the files. This occurred in a lot of files and hence I cannot manually correct all of them. Can someone help me solve this?

Syntax error:

And then the installation ends with an error:

I am positive that all the dependencies are met, never the less, I will check again.

Thank You.

If you want to build plone-react locally just follow the steps mentioned in file, That should work.Yes there are some errrors which will probably go once we upgrade to react-16.

Thank You for replying, That is the file I am following,
step 1: yarn install -- done
step 2: Install backend, in the api directory run, To run this script I have to first "make", The errors above are result of the "make" command.

So the isn't working on your side? Why are you using make command, it isn't needed I guess.

I have got both python2.7 and python3 on my linux, For some reason when I run, It is defaulting to python3, Is it fine to edit the to tun with python2?

virtualenv --clear . in is setting up python3.5 and not python2.7, How do I force it to setup python2.7

Thank You.

Have you tried installing and running plone from ?You can run plone directly in a seperate command line as it listens to port 8080 same as it does in api/ As for me both methods should work, the problem is not with bootstrap script i guess, you should install python 2.7 with virtualenv and buildout , please refer to the above link for installation instructions.

I think I figured out the problem, has the following commands

  1. rm -r ./lib ./include ./local ./bin
  2. virtualenv --clear .
  3. ./bin/pip install -r
  4. ./bin/buildout "$@"

1 just clears out files for a fresh installation
2 creates a bin and an includes folder where python libraries are held, If you installed virtualenv with pip3 the python3.5 is the default python of use.
3 Similarly ./bin/pip == ./bin/pip3
I installed virtualenv with pip2 and it seems the previous errors are gone.

Now there is a different error Error: Couldn't find a distribution for 'zope.i18n[zcml]==4.2.0'. How do i solve this?

As mentioned, I have installed Plone separately, Hopefully it works. But can you please tell me why the isn't working?

Thank You.

Am sorry to keep bugging you.
As suggested I have installed plone separately and successfully ran the frontend.
There seems to be no problem in running either of them.
But when i visit localhost:4300, I am presented with Something went wrong: Cannot read property 'replace' of undefined. Please guide me on how to resolve this.
Thank You.

Could you please file an issue on the github issue tracker for this. We really have to put some effort into making this easier for GSoC students...

@adithya Yes , let's talk there in the github issue thread istelf .Create a issue about this and make sure you log all the errors causing.

@tisto @nileshgulia1
Please find the issue at