Eea.facetednavigation and custom list index not filtering

I would just like to share that I encountered some issues trying to use a custom list index as one of the facets in a container with facetednavigation enabled. For some reason facetednav does not filter if I use the custom list index. I have inspected the index and the vocabulary I used. All are in order. I upgraded to the latest version of eea.facetednavigation and I even tried upgrading my buildout.

The weird thing was that a different buildout pinned to the same Plone version behaved differently. It worked in the other buildouts (same version and upgraded). The version pins are all the same. I tried removing the ZODB and I get the same behavior. Finally, when I deleted the blobstorage/* files and restarted, it now works in the problematic buildout.

What could be the reason that filtering via my custom list index did not work? Is there something in blobstorage that facetednavigation uses? Maybe a cached item in blobstorage/tmp ?

What do you expect to happen? How do you configure the list index? Do you add and configure a Checkbox Widget for FacetedNavigation? Some screenshots might be helpful here.

Basically my custom list index is supposed to function the same as the default "Tags" index. In this case, i used a checkbox widget. I also tried select. They behave the same and no results are returned when a value is ticked. The problem only manifested in one development buildout. It works as it is supposed to in other buildouts using the same package. It was something in that particular buildout. It got resolved after deleting the contents of var/blobstorage/. Note that this buildout was used for development and before the programming of the vocabulary source and index was completed various errors were experienced. But even after the code got right the filtering in this buildout did not work at all. Even if packages were updated and the buildout package itself was updated to Plone 4.3.9

Any ideas?


No idea. If there's video recording to show how you do it, we might have chance to figure out where goes wrong. At least some screenshots of your EEA widget configuration might be helpful.

Thanks. I will not add screenshots anymore. It is just configured normally. I posted this issue because the information might help someone in the future.