Dexterity richtext content is not showing after upgrade


I recently upgraded from 4.3.12 to 4.3.14. I notice now ( but this could be due to a previous update ) that dexterity richtext fields are not shown anymore.

They are displayed as
RichTextValue object. (Did you mean .raw or .output?)

Editing the page shows the richtext widget with the proper content.

These dexterity objects are 100% TTW ( they are just forms which several compulsory fields )

It seems that this "RichTextValue object. (Did you mean .raw or .output?)" sentence is referenced many times on the internet by google

I guess some widget template has changed. Likely candidates are somewhere in z3c.form, or
I ran into something similar for indexing the value of a richtext field:

So no definitive answer, but maybe this points you in the right direction.

I notice it is the same behaviour for a newly created 4.3.14 site.

I have it in Plone 5.1, too

I investigated a bit more. This was introduced in 1.2.8 because of the changes made in this pull request. Pinning back to 1.2.7 fixes it and seems fine: you are only missing a new feature then.
I will open an issue.

Issue created:

thanks that fixes this bug :wink:

1 Like

@espen, do you really see this in Plone 5.1? I only see it in 4.3. I tried with buildout.coredev 5.0 and 5.1 and the rich text shows up fine there.

I am on vacation, but yes I see it in 5.1 Maybe it could be some add on that requires some (wrong) versions?

Switching back to 1.2.7 or upgrading its version pin to 1.2.9 should solve the problem.