Confused with VirtualHostBase [RESOLVED]


I did a proxy_reverse directive with VirtualHostBase, and it works now, but when I tried to click a link, it returns to domain:8080 port, I need to know what its wrong with..

Simply I dont get it..

It supposer it should work fine, this is the Nginx configs:

 add_header X-Frame-Options "SAMEORIGIN";
 add_header Strict-Transport-Security "max-age=15768000; includeSubDomains";
 add_header X-XSS-Protection "1; mode=block";
 add_header X-Content-Type-Options "nosniff";
 add_header Content-Security-Policy "default-src 'self'; img-src *; style-src 'self' 'unsafe-inline'; script-src 'self' 'unsafe-inline' 'unsafe-eval'";
 add_header Content-Security-Policy-Report-Only "default-src 'self'; img-src *; style-src 'self' 'unsafe-inline'; script-src 'self' 'unsafe-inline' 'unsafe-eval'";

upstream plone {

server {
	listen 80;
	listen [::]:80;


	access_log /var/log/nginx/0Hxff.ca_access.log;
	error_log /var/log/nginx/0Hxff.ca_error.log;

	location / {
		proxy_pass http://plone/VirtualHostBase/http/;


Replace the ':8080' bit from the proxy_pass line with ':80'

Thank you jaroel, that was the problem, I have fixed and now it works fine..! I was confusing with VirtualHostBase works..!

Thank you..!