I am upgrading Plone from 3 to 5 process I followed:
Installed Plone 5 andded my SRC content and ran buildout. Everything is working fine and I can see my Products. Then I added
to filestorage and ran buildout again. Now I see a screen

If I click on View your Plone site, I get ComponentLookupError(, '') (Also, the following error occurred while attempting to render the standard error message, please see the event log for full details: (, ''))

In client logs:

2017-03-29T00:04:18 INFO ZEO.ClientStorage zeostorage Server authentication protocol None

2017-03-29T00:04:18 INFO ZEO.ClientStorage zeostorage Connected to storage: ('localhost', 8100)

2017-03-29T00:04:18 INFO ZEO.ClientStorage zeostorage No verification necessary -- empty cache

2017-03-29T00:04:30 INFO Plone OpenID system packages not installed, OpenID support not available

2017-03-29T00:05:56 INFO Zope Ready to handle requests

2017-03-29T00:09:13 INFO PythonScripts Some of your Scripts have stale code cached. Since Zope cannot use this code, startup will be slightly slower until these Scripts are edited. You can automatically recompile all Scripts that have this problem by visiting /manage_addProduct/PythonScripts/recompile of your server in a browser.

2017-03-29T00:09:18 ERROR Zope.SiteErrorLog 1490726358.550.583683787333
Traceback (innermost last):
Module ZPublisher.Publish, line 127, in publish
Module ZPublisher.BaseRequest, line 444, in traverse
Module ZPublisher.BeforeTraverse, line 97, in call
Module Products.CMFCore.PortalObject, line 82, in before_publishing_traverse
Module Products.CMFCore.DynamicType, line 147, in before_publishing_traverse
Module Products.CMFDynamicViewFTI.fti, line 230, in queryMethodID
Module Products.CMFDynamicViewFTI.fti, line 191, in defaultView
Module Products.CMFPlone.PloneTool, line 733, in browserDefault
Module Products.CMFPlone.PloneTool, line 604, in getDefaultPage
Module Products.CMFPlone.defaultpage, line 140, in get_default_page_via_view
Module Products.CMFPlone.browser.defaultpage, line 17, in getDefaultPage
Module Products.CMFPlone.defaultpage, line 92, in get_default_page
Module zope.component._api, line 169, in getUtility
ComponentLookupError: (, '')

2017-03-29T00:09:19 ERROR root Exception while rendering an error message
Traceback (most recent call last):
File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/OFS/", line 242, in raise_standardErrorMessage
v = s(**kwargs)
File "/usr/local/Plone/buildout-cache/eggs/Products.CMFCore-2.2.10-py2.7.egg/Products/CMFCore/", line 127, in call
return, *args, **kw)
File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Shared/DC/Scripts/", line 322, in call
return self._bindAndExec(args, kw, None)
File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Shared/DC/Scripts/", line 359, in _bindAndExec
return self._exec(bound_data, args, kw)
File "/usr/local/Plone/buildout-cache/eggs/Products.PythonScripts-2.13.2-py2.7.egg/Products/PythonScripts/", line 344, in _exec
result = f(*args, **kw)
File "Script (Python)", line 39, in standard_error_message
File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Shared/DC/Scripts/", line 322, in call
return self._bindAndExec(args, kw, None)
File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Shared/DC/Scripts/", line 359, in _bindAndExec
return self._exec(bound_data, args, kw)
File "/usr/local/Plone/buildout-cache/eggs/Products.CMFCore-2.2.10-py2.7.egg/Products/CMFCore/", line 237, in _exec
result = self.pt_render(extra_context=bound_names)
File "/usr/local/Plone/buildout-cache/eggs/Products.CMFCore-2.2.10-py2.7.egg/Products/CMFCore/", line 177, in pt_render
self, source, extra_context
File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.13.24-py2.7.egg/Products/PageTemplates/", line 87, in pt_render
File "/usr/local/Plone/buildout-cache/eggs/zope.pagetemplate-3.6.3-py2.7.egg/zope/pagetemplate/", line 132, in pt_render
strictinsert=0, sourceAnnotations=sourceAnnotations
File "/usr/local/Plone/buildout-cache/eggs/", line 98, in call
return self.template.render(**kwargs)
File "/usr/local/Plone/buildout-cache/eggs/", line 163, in render
return base_renderer(**context)
File "/usr/local/Plone/buildout-cache/eggs/Chameleon-2.24-py2.7.egg/chameleon/zpt/", line 261, in render
return super(PageTemplate, self).render(**vars)
File "/usr/local/Plone/buildout-cache/eggs/Chameleon-2.24-py2.7.egg/chameleon/", line 191, in render
raise_with_traceback(exc, tb)
File "/usr/local/Plone/buildout-cache/eggs/Chameleon-2.24-py2.7.egg/chameleon/", line 171, in render
self._render(stream, econtext, rcontext)
File "", line 743, in render
File "", line 652, in render_master
File "/usr/local/Plone/buildout-cache/eggs/", line 161, in call
return base()
File "/usr/local/Plone/buildout-cache/eggs/", line 81, in language
aq_inner(self.context).Language() or self.default_language()
File "/usr/local/Plone/buildout-cache/eggs/plone.memoize-1.2.0-py2.7.egg/plone/memoize/", line 67, in memogetter
value = cache[key] = func(*args, **kwargs)
File "/usr/local/Plone/buildout-cache/eggs/", line 75, in default_language
registry = getUtility(IRegistry)
File "/usr/local/Plone/buildout-cache/eggs/zope.component-3.9.5-py2.7.egg/zope/component/", line 169, in getUtility
raise ComponentLookupError(interface, name)
ComponentLookupError: (, '')

  • Expression: "portal_state/language"
  • Filename: ... egg/Products/CMFPlone/browser/templates/
  • Location: (line 12: col 11)
  • Source: lang portal_state/language;
  • Arguments: repeat: {...} (0)
    template: <ImplicitAcquisitionWrapper default_error_message at 0x750ef50>
    modules: <instance - at 0x277e7a0>
    here: <ImplicitAcquisitionWrapper Plone at 0x70ef280>
    user: <SpecialUser - at 0x37e7c50>
    nothing: <NoneType - at 0x7f9b18e99f00>
    container: <ImplicitAcquisitionWrapper Plone at 0x70ef280>
    default: <object - at 0x7f9b19074580>
    request: <instance - at 0xbe9cab8>
    wrapped_repeat: <SafeMapping - at 0x7498a48>
    traverse_subpath: <list - at 0xc2c0ab8>
    loop: {...} (0)
    context: <ImplicitAcquisitionWrapper Plone at 0x70ef280>
    translate: <function translate at 0xa2cad70>
    root: <ImplicitAcquisitionWrapper Zope at 0x70ef050>
    options: {...} (9)
    target_language: <NoneType - at 0x7f9b18e99f00>

Can someone help me with this

It sounds like you have all the code updated, but the Data has not been migrated. When you go to the ZMI, does it tell you that your Plone site is out of date and needs to be migrated? Try to run the migration.

I'm guessing the migration will likely fail, if you are trying to go straight from Plone 3 to Plone 5. See, and check out the rest of the upgrade guide there in the docs for more tips.

When I try to visit zmi it asks for username and password. I enter the credentials which I used while installing plone but it says invalid credentials.

Any Idea about this

If you have replaced the Data, it will be the credentials from that data. If you don't remember/know the un/pw, you can create a new user from the command line:

$ bin/instance adduser [username] [password]

I have a zeocluster setup, so should I add instance in buildout and install it.
I tried bin/client1 adduser [username] [password] earlier but it didnot worked

instance is the same as client1, just depends on your setup, so you don't need to change anything.

did you get an error when you tried to run adduser? If not, try to log into the root of the ZMI instead of into the Plone site -

I tried this and it worked but when I go to portal_migration it shows my site is uptodate

Are you sure you have all the add-ons required by your old Data.fs?


did you customise any templates TTW ( for example in /portal_skins/custom ?).

If so, remove them

Are you following this procedure?