Cannot edit content on Plone5 with Chrome

Hi all,

So, I'm trying to launch a Plone5 site, and I've found I can't edit content using Chrome. I get the same error WordPress was having at

I have had a look at Products.TinyMCE and found that the Plone5 distribution is unmaintained.

I have to admit, I'm a little shocked by this. Should I move back to Plone 4?


Is this 5.0.5? Which OS and browser version? I can't reproduce. Could you please check if you can in any of these sites?

Yep, Plone 5.0.5. I see the same error on To test it, select some text and attempt to make it bold.

Chrome Version 51.0.2704.103 (64-bit) on macOS 10.11.6.

I assume you meant, right? I just tried Bold and it worked there. Using Chrome 51 on Windows. Gonna try OSX and Linux now.

Yep, I meant .de. Sorry!

Looks like CMFPlone master has been brought up to 4.3.12, whereas 5.0.5 is on 4.3.4. The fix for this bug was apparently added in 4.3.10.

Okay, so, I was confused by the P.TinyMCE tag in 5.x, I thought the mockups were just wrapping the old integration. I've managed to get on the right track now, TinyMCE version upgrade is fixing it. Fixing up a PR now.