Buildout error upgrading from 5.1.6 to 5.2.1


I'm trying to upgrade from 5.1.6 to 5.2.1.

I originally installed Plone with the Unified Installer.
I successfully upgraded from 5.1.2 to 5.1.6.

Now I'm trying to get to 5.2.1 and am having an error when I run buildout:

Could't load zc.buildout entry point default
from plone.recipe.zope2instance:
(zc.buildout 2.11.2 (/var/www/comet-up/comet/lib/python2.7/site-packages), Requirement.parse('zc.buildout>=2.12.0 '), set(['zc.recipe.egg'])).
Getting section instance.
Initializing section instance.
Loading zc.buildout recipe entry plone.recipe.zope2instance:default.

An internal error occurred due to a bug in either zc.buildout or in a
recipe being used:
Traceback (most recent call last):
File "/var/www/comet-up/comet/lib/python2.7/site-packages/zc/buildout/", line 2127, in main
getattr(buildout, command)(args)
File "/var/www/comet-up/comet/lib/python2.7/site-packages/zc/buildout/", line 681, in install
[self[part]['recipe'] for part in install_parts]
File "/var/www/comet-up/comet/lib/python2.7/site-packages/zc/buildout/", line 1278, in getitem
File "/var/www/comet-up/comet/lib/python2.7/site-packages/zc/buildout/", line 1386, in _initialize
File "/var/www/comet-up/comet/lib/python2.7/site-packages/zc/buildout/", line 1392, in initialize
recipe_class = _install_and_load(reqs, 'zc.buildout', entry, buildout)
File "/var/www/comet-up/comet/lib/python2.7/site-packages/zc/buildout/", line 1347, in _install_and_load
req.project_name, group, entry)
File "/var/www/comet-up/comet/lib/python2.7/site-packages/pkg_resources/", line 587, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/var/www/comet-up/comet/lib/python2.7/site-packages/pkg_resources/", line 2800, in load_entry_point
return ep.load()
File "/var/www/comet-up/comet/lib/python2.7/site-packages/pkg_resources/", line 2430, in load
self.require(*args, **kwargs)
File "/var/www/comet-up/comet/lib/python2.7/site-packages/pkg_resources/", line 2453, in require
items = working_set.resolve(reqs, env, installer, extras=self.extras)
File "/var/www/comet-up/comet/lib/python2.7/site-packages/pkg_resources/", line 890, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (zc.buildout 2.11.2
Requirement.parse('zc.buildout>=2.12.0'), set(['zc.recipe.egg']))

I have the following pinnings in my buildout.cfg

zc.buildout = 2.13.3
zc.recipe.egg = 2.0.7
plone.recipe.zope2instance = 6.6.0

I'm not sure what ContextualVersionConflict means or what do about the zc.buildout>=2.12.0 requirement, as I'm already pinned at a higher version.

Thank you in advance

Just as an FYI, I tried upgrading a bunch of ways (with plugins, without plugins, incrementally, pinning packages...) - the only way I got to work was to do a fresh install of 5.2.1 via unified installer, copy over data, and pick out items from buildout.cfg.

It looks like your current bin/buildout script uses zc.buildout 2.11.2, and it is not getting updated automatically to a higher version.

Options to try:

  • Run bin/buildout -n to run buildout in newest mode. That may cause it to look for the correct version.
  • Run bin/pip install -r requirements.txt, if such a file exists. That file should have a line with zc.buildout == 2.13.3 to match the version in versions.cfg.
  • Or specify a version yourself on the command line: try bin/pip install -U zc.buildout==2.13.3.

Plone Foundation Code of Conduct