Bootstrap Plone 3 with ancient

hope:buildout-legacy peter$ python2.4 
Traceback (most recent call last):
  File "", line 170, in ?
  File "<string>", line 103, in use_setuptools
  File "<string>", line 97, in do_download
  File "<string>", line 158, in download_setuptools
  File "/opt/local/lib/python2.4/", line 130, in urlopen
    return, data)
  File "/opt/local/lib/python2.4/", line 364, in open
    response = meth(req, response)
  File "/opt/local/lib/python2.4/", line 471, in http_response
    response = self.parent.error(
  File "/opt/local/lib/python2.4/", line 402, in error
    return self._call_chain(*args)
  File "/opt/local/lib/python2.4/", line 337, in _call_chain
    result = func(*args)
  File "/opt/local/lib/python2.4/", line 480, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 403: SSL is required
hope:buildout-legacy peter$ 

I'm trying to bootstrap an old Plone 3 site but running into the http/https problem with pypi...
Which should I use or what part do I have to change?
I tried with python2.4 --download-base= but no luck
I also tried with python2.4 --download-base= but then zc.buildout is not found
Any other ideas?

Yeah... I have since some time these notes for a blog post

virtualenv -p python2.7 /tmp/virtualenv
cd /tmp/virtualenv/
 ./bin/pip install virtualenv==1.7.2
mkdir /tmp/pypi-local
/tmp/virtualenv/bin/virtualenv -p python2.4 . --extra-search-dir=/tmp/pypi-local --never-download --no-site-packages
./bin/pip install

The trick is that first you install an old virtualenv version for python 2.7, then you download locally old version for pip and setuptools, then again you bootstrap a python2.4 virtualenv using that files.

Of course you need to override the buildout index:

index =

I hope it is clear enough :slight_smile:

If not I will write a blog post :stuck_out_tongue:


Locate where comes from (if you are lucky, then you find it in Change it to Try again.

@dieter tried that...

@alert Wow, thanx!

1 Like

If you use the Python 2.4 that came with UnifiedInstaller, it's compiled without ssl support. I'm posting it here if someone has the same problem as you but it's using the Python from the UnifiedInstaller.