Basic site structure/layout advice

I think it's looking for a particular CSS ID to do that with JavaScript. If you can figure out how it does it on the normal link, you can make it do it on your new one too. But mostly I don't think anyone will notice or care that the selected tab isn't quite correct.

I now am beginning to understand why you mentioned the /contact-info page is not a "real content" item. I spent the last hour looking for a way to edit it but came away empty handed.

Any idea on how to edit that page, or would better practice be to create an entirely new Contact page?

Yes, you can do that with Products.PloneFormGen or collective.easyform. Then you modify the "contact" portal action (the thing that makes the link appear at the footer) so instead of sending to contact-info it sends to (say) contact (assuming you give your new contact form the ID "contact").

Customizing the built in contact form was easier in Plone 4, and not very easy in Plone 5 (requires coding).

[quote="tkimnguyen, post:23, topic:3701"]
Yes, you can do that with Products.PloneFormGen or collective.easyform
[/quote]Thanks -- I have installed the first add-on for testing tomorrow.

Is the large gray box on the default theme homepage meant for holding an image? I planned to fish around Admin > Site Setup > Theming > Barceloneta Theme Copy > Modify Theme > but nothing is happening -- it just says "loading".

Any idea how to fix this?

Maybe post a screen shot of the area you mean...

Yeah. I am wanting to insert an image inside the highlighted box since I assume it's an image placeholder, yes?

I found my way to Admin > Site Setup > Theming > Barceloneta Theme Copy > Modify Theme but nothing happens other than "Loading":

An out of the box default home page looks like this:

and you should be able to edit it with the usual TinyMCE editor, which lets you insert images:

Don't know what's up with your theming control panel.

[quote="tkimnguyen, post:27, topic:3701"]
edit it with the usual TinyMCE editor
[/quote]I'm familiar with TinyMCE -- many CMS platforms use it. One would think it would be straightforward to insert an image. However, I see no way of uploading an image in Plone using the editor -- there's no way to select an image. If you do, please tell me where I have gone wrong. Here's a screenshot of what I see when I attempt to upload an image:

Neither do I. I Googled "Plone theme editing" and made my way to that page but it only says "Loading". I have no clue why nothing loads.

I've barely done more than add my logo and edit the homepage text yet I keep stumbling across things like this that are simply broken. Plone does not come across as a robust platform -- it seems to be an extremely fragile CMS. I feel like one must have sadomasochistic tendencies to use this CMS.

Using Plone so far has been very unenjoyable, but the community has kept me in it.

Modify Theme but nothing happens other than "Loading":

Try removing everything after the ?-mark in the url and reload the page

@ron_jeremy is a big shame that the "hero" element on the default theme was designed to be theme only editable rather part of the content.

How we normally deal with this for clients is to use something like portletpage or contentwellportlets to provide a user editable element in similar to this. You can also things like collective.carousel. On plone5 we use mosaic. Hopefully in plone 6 we will fix some of the mistakes and make more things easier to customise in the default setup.

If you do want to continue down the route of modifying your theme then I'd suggest making a copy on the filesystem in your local development environment as its nicer to edit and reloads faster. As you have found out, certain version of plone have a broken theme editor. Sorry about that.

@ron_jeremy for theming I would go with a Theme Package as Dylan said.
Start here: https://training.plone.org/5/theming/theme-package.html
If you have questions regarding the theming training, feel free to ask.

Depends on the version of Plone. The latest ones I've been running have that editable in TinyMCE. I've been able to add images there the usual way.

@ron_jeremy could you tell us (sorry if repeating yourself) what operating system, which version of Plone, which installer you used, what is in your buildout.cfg, and which browser and browser version you're seeing this with? You could try a different browser or you could look at the browser inspector console to try to track down the specific problem.

Thanks for offering to help, but it did not remedy the problem.

[quote="djay, post:30, topic:3701"]
As you have found out, certain version of plone have a broken theme editor. Sorry about that.
[/quote]Thanks for the thoughtful reply. I could understand having issues if I were using some highly customized theme. However, encountering problems like this -- very basic core problems -- while using the theme that ships with the CMS is extremely troubling.

The default Plone 5 theme absolutely must be a rock -- a rock that newbies can pound on yet still remains standing. A theme that breaks easily or is plagued with core issues does not give one much confidence to use as a foundation for their online presence.

I use Chrome or Safari -- both are up to date, and both browsers display the same "Loading" page when I click on "Modify Theme" in the Theming section.

Plone Details:

Version Overview
Plone 5.0.6rc1 (5016)
CMF 2.2.10
Zope 2.13.24
Python 2.7.12+ (default, Sep 17 2016, 12:08:02) [GCC 6.2.0 20160914]
PIL 3.3.1 (Pillow)
You are running in "production mode". This is the preferred mode of operation for a live Plone site, but means that some configuration changes will not take effect until your server is restarted or a product refreshed. If this is a development instance, and you want to enable debug mode, stop the server, set 'debug-mode=on' in your buildout.cfg, re-run bin/buildout and then restart the server process.

OS Details:

ron_jeremy@hd-power-equipment-plone-site:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.10
Release: 16.10
Codename: yakkety

Buildout.cfg Details (I tried to copy/pasted as best I could):

ron_jeremy@hd-power-equipment-plone-site:~/Plone$ cd zeocluster
ron_jeremy@hd-power-equipment-plone-site:~/Plone/zeocluster$ nano buildout.cfg
[buildout]
Plone Component Versions
This version of the Unified Installer has the components of Plone 5
preloaded so that it can install without an Internet connection.
If you want to update, uncomment the "http://..." line below,
edit it to point to the current version URL, comment out the
"versions.cfg" line and run "bin/buildout" while attached to the
Internet. Generally, you only want to do that as part of a planned migration.
Note that if you are updating components, you should also check the versions
section at the end of this file, since recipes or components other than
those of Zope and Plone may need updating at the same time.
extends =
base.cfg
versions.cfg
http://dist.plone.org/release/5.0.6/versions.cfg
If you change your Plone version, you'll also need to update
the repository link below.
find-links +=
http://dist.plone.org/release/5.0.6
If you try to start Zope as root, it will change user id to run as
the effective user specified here. This user id must own the var directory
of your buildout.
effective-user = ron_jeremy
This user will own the rest of the installation, and should be used to
run buildout.
buildout-user = ron_jeremy
A flag to tell the Unified Installer whether or not to document sudo use.
need-sudo = no
Eggs
Add an indented line to the eggs section for any Python

Thanks very much for your input -- that looks like a big job. I'll go down that rabbit hole on the weekend to see where it takes me.

Update: I'm going to take the liberty of saying it's not likely a coincidence that I cannot add an image because the "Contents" icon is again no longer working (does not list any contents).

I have decided to dump Plone for now. I feel that no matter how far I go with this CMS, the Contents function will eventually break and leave me dead in the water again. I am nuking my Plone site for now because I simply do not trust this platform. I will check back with the community when Plone 6 is released.

@ron_jeremy to be fair, no one has every reported nuking their contents feature before to my knowledge. It would certainly be good to know what js error you were getting in your console so we can try an work out what you were doing to cause this. Without more detail from helpful people such as yourself it might not get fixed.

@dylan I have a Plone 5.0.6 site that exhibits this or similar behaviour (by which I mean that the symptom is a blank "content" tab). I ran out of time when I was working on it and had to drop back to Plone 4.3.11 for that project, but based on this thread I will revisit it to ensure that it is a reproducible problem, and if it is we can pick up where @ron_jeremy left off and hopefully get to the bottom of it.

1 Like