Addon In Docker Not Adding/Erroring Plone Version 5.1

The error message informs your about a (file system) permission problem. Your options:

  • grant the permission to the user running buildout
  • change the owner of the folder to the user running buildout
  • run buildout as a user with write permissions to the folder.

I am working on using plonecli as you recommended. I will reach out with either further questions or my results tomorrow afternoon. This is a new tool for me.
We are using docker because I am helping my team through the training and we want to all be working on the same "machine" so we can work through things knowing we are using the same tools.
I shall be in touch with work tomorrow. Thank you for the suggestions and video. Very kind.

I'd say use plonecli and follow @pigeonflight's instructions (cheers David, bookmarked). This should give you a working buildout.cfg.

We tried chown root:root -R src/ and a few other things and where not able to get the error to change from the permissions error. We have decided to stop with our training. We are going to look into a training in Plone. Thank you so much for your help and suggestions.

I was not able to get plonecli after it installed to run, the command was not found. I think how our docker container is created is off. We are new to docker but I assume it is at our foundation the root of our issue will be found. We have decided as a team to stop our training until get a professional training. Thank you so much for your time and efforts. I am sure in the weeks to come your suggestions will all make sense and the points will connect.

Dear Community,
At this time we are stopping our training. Since there is no resolution to our issue I am not certain what this community's protocol is for closing threads. Please let me know if there are further steps I should take to close this posting. Thank you all for your time and knowledge. If ever it becomes clear where we erred I will of course share the resolution.
Sincerely,
Lauren

@laurengordonfahn,
Before you throw in the towel, one more question. What command did you use to install plonecli and on what operating system?

As one of the authors of the training you are trying to follow: Sorry it does not work for you. It should be said that the instructions state that you should either use a local setup or vagrant:
https://training.plone.org/5/plone_training_config/instructions.html

Following the training with docker has never been tested or documented. Personally I never use docker for development so far. Would is be usefull improvement if we added that?

Also: We're planning to produce a new and shorter "Developer Quickstart Guide" that begins with file-system based development using Python. We hope to have it ready for the training at the conference:

@pbauer We tried to set it up with both local and vagrant. And couldn't get that up and running either the errors were earlier on. So we moved forward with docker because that allowed up the greatest success and was going to allow us to all be in step with each other that is the full story on how docker came into our training. We look forward to seeing what comes out next on the training front. Perhaps I shall see you in Italy.

@pigeonflight
I tried installing plonecli both in the docker container and outside the container
outside the container: pip install plonecli --user
plonecli -l

inside I don't full recall but I think it was just pip install plonecli because user is not part of the directory.
Both times the command ran to completion but I didn't have access to the plonecli commands

we are on mac os the team has all different versions but I assume that shouldn't matter. I am on macOS Mojave. Thank you for your questions. Have a good weekend.

@laurengordonfahn,
The --user option causes plonecli to be added to $HOME/.local/bin.
On mac and linux you can call it by using the full path to the command as follows:

$HOME/.local/bin/plonecli

The ideal approach is to add $HOME/.local/bin/ to your PATH.
This will allow you to call the command without the full path. To achieve this temporarily, use the command:

export PATH=$PATH:$HOME/.local/bin

To make this permanent add that command to your profile (most likely ~/.bashrc or ~/.bash_profile).

Hello @pigeonflight ,
I have tried this process and must be missing something. One of the more senior members of my team is going to give it a whirl tomorrow. If he is unsuccessful then I shall post the steps that I took and see if you can spot where I went wrong. Life is but a game (shrug). As always thank you for your continued thoughts and support.

So the plonecli command is being found now?

My apologies @pigeonflight, I had intended to reach out much sooner. We have not been able to get the plonecli to function even when we open access to where it is installed. Our training begins after Labor day with Plone and so have set it aside to complete a few other projects before diving back into Plone. We shall not abandon the Plone ship. In our training when what was going wrong in our system set up becomes clear I shall post again. I am so sorry to have not responded earlier. The days toss me around a little bit recently. To a lovely start to August. Truly, thank you for all of your energies.

Well all the best until you return to the Plone "slog" :).

It seems that the fix was to use a line like

develop = src/ploneconf.site

Plone Foundation Code of Conduct