Adding an add-on in site

Hi, i added an add-on to my plone site by the name of collective.easyslider. it added successfully i restarted my buildout but could not found it in the add-ons to install it or is there anyother place in the site where i can find it.

Have you add the AddOn in the egg Section and the zcml Section in the buildout?

yes sir. i did then i restarted the buildout.

the problem is that i can not find it in add-on installation section to install. If you can tell me any other location where i can find it and how can i place it on my front page

go to ZMI Portal Quickinstaller

im there but even there it is not available.

that is how it looks like, the black is when i installed it and the white is the zmi interface

Check if the module is listed in the bin/instance script generated by buildout.
If yes, check if the situation changes if you add the module also to the zcml slug of your buildout configuration.


Not all add-ons need to be explicitely installed in the individual portals - for some it is sufficient that there code is available; others require code and import of their ZCML registrations; and some require in addition explicite installation in the individual portals. The last is usually required when the add-on wants to adapt the portal's configuration in the ZODB.

I do not know to what add-on class "collective.easyslider" belongs. Have you read (and followed) any available installation instructions?

If something is called easy be careful....

General checks by using github - easy to do:

i had been through the documentation but still not clear. installed but still not available in addons section and ZMI Portal Quickinstaller. Plone has become a headache, more than that. A single add-on takes a complete day. pufff

I have installed it 100 times, I am pretty sure you are doing something wrong .

If you use Plone 5, it is not compatible yet.
Are you sure your buildout finished successfully ( my guess is that it stopped because of pinned versions)

If it really did not install , try using version 1.3.x or 1.4.0